import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+)\\s+(\\S+)\\s+(\\S+)\\s+(\\S+)\\s+(\\S+)\\s+(\\S+)(?:[ ]+(.*))?";
final String string = "Interface Link Speed Duplex Type PVID Description \n"
+ "BAGG51 UP 4G(a) F(a) T 1 \n"
+ "FGE1/0/42 DOWN auto A T 1 ### LIVRE ###\n"
+ "GE6/0/20 UP 100M(a) F(a) A 1 LIVRE (MGMT - [WAN8-P8] ";
final String subst = "$1;$2;$3;$4;$5;$6;$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}