re = /"[^"\/]*\/[^"]*\.[\w:]+(?:\.[\w:]+)*"/m
str = 'someFunction("Default","Asset/NiceAssetTab/Lighting/MuchLighting.act")
someFunction("Default","Asset/NiceAssetTab/Lighting/MuchLighting..")
SavedTableHash = "2/6ijbfpfKhSdhJa3iiSuw=="'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result