import Foundation
let pattern = #""[^"\/]*\/[^"]*\.[\w:]+(?:\.[\w:]+)*""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
someFunction("Default","Asset/NiceAssetTab/Lighting/MuchLighting.act")
someFunction("Default","Asset/NiceAssetTab/Lighting/MuchLighting..")
SavedTableHash = "2/6ijbfpfKhSdhJa3iiSuw=="
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)