package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)tooltipid: \[(.*)\]`)
var str = ` coordinateid: [20,54.1],
colorid: [250,0,0],
sizeid: [2000],
tooltipid: [B],`
var substitution = "tooltipid: ['$1']"
fmt.Println(re.ReplaceAllString(str, substitution))
}