import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tooltipid: \\[(.*)\\]";
final String string = " coordinateid: [20,54.1],\n"
+ " colorid: [250,0,0],\n"
+ " sizeid: [2000],\n"
+ " tooltipid: [B],";
final String subst = "tooltipid: ['$1']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}