#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?<fieldname>[^>]+)>(?<fieldvalue>[^<]*)<\/\1>"
Local $sString = "<Vuln>" & @CRLF & _
"<CrawlTraffic>UE9TVCAvcnUvY29udHJhY3RvcnMvdGVuZGVycy9yZXF1ZXN0LyBIVFRQLzEuMQ0KQWNjZXB0OiB0ZXh0L2h0bWwsYXBwbGljYXRpb24veGh0bWwreG1sLGFwc=</CrawlTraffic>" & @CRLF & _
"</Vuln>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")