const regex = /<(?<fieldname>[^>]+)>(?<fieldvalue>[^<]*)<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?<fieldname>[^>]+)>(?<fieldvalue>[^<]*)<\\\/\\1>', 'gm')
const str = `<Vuln>
<CrawlTraffic>UE9TVCAvcnUvY29udHJhY3RvcnMvdGVuZGVycy9yZXF1ZXN0LyBIVFRQLzEuMQ0KQWNjZXB0OiB0ZXh0L2h0bWwsYXBwbGljYXRpb24veGh0bWwreG1sLGFwc=</CrawlTraffic>
</Vuln>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}