using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<fieldname>[^>]+)>(?<fieldvalue>[^<]*)<\/\1>";
string input = @"<Vuln>
<CrawlTraffic>UE9TVCAvcnUvY29udHJhY3RvcnMvdGVuZGVycy9yZXF1ZXN0LyBIVFRQLzEuMQ0KQWNjZXB0OiB0ZXh0L2h0bWwsYXBwbGljYXRpb24veGh0bWwreG1sLGFwc=</CrawlTraffic>
</Vuln>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}