# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\-\..*)//gm;t' <<< "filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov"