using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\-\..*)";
string substitution = @"";
string input = @"filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}