#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<Product>\S+)\s+(?<StandardPack>\d+)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Project Contact(s):" & @CRLF & _
"abc@gmail.com" & @CRLF & _
"xyz@outlook.com" & @CRLF & _
"Demo@gmail.com" & @CRLF & _
"" & @CRLF & _
"Link" & @CRLF & _
"" & @CRLF & _
"to manage Quota Target" & @CRLF & _
"PC\Lapto\Notebook 150" & @CRLF & _
"Tablet\Smartphone 45 " & @CRLF & _
"Samp" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")