$re = '/(?<Product>\S+)\s+(?<StandardPack>\d+)/mi';
$str = '
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link
to manage Quota Target
PC\\Lapto\\Notebook 150
Tablet\\Smartphone 45
Samp
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);