use strict;
my $str = '
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link
to manage Quota Target
PC\\Lapto\\Notebook 150
Tablet\\Smartphone 45
Samp
';
my $regex = qr/(?<Product>\S+)\s+(?<StandardPack>\d+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}