// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?<Product>\S+)\s+(?<StandardPack>\d+)").unwrap();
let string = "
Project Contact(s):
abc@gmail.com
xyz@outlook.com
Demo@gmail.com
Link
to manage Quota Target
PC\\Lapto\\Notebook 150
Tablet\\Smartphone 45
Samp
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}