using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ([^\\s].+):([0-9]+)([0..9]*?)\n (.+)";
string input = @" test/blockade_test.exs:57
Expected truthy, got false";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}