$re = '/ ([^\\\\s].+):([0-9]+)([0..9]*?)\n (.+)/';
$str = ' test/blockade_test.exs:57
Expected truthy, got false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);