#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)::\h+[^:\r\n]+:\h+\K.+"
Local $sString = "April 01 2020 Key Information Read :: Interesting Character #1: Kermit the Frog" & @CRLF & _
"April 01 2020 Key Information Read :: Interesting Character #2: Miss Piggy" & @CRLF & _
"April 01 2020 Key Information Read :: Their Best Movie: The Muppet Movie (1979)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")