import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "::\\h+[^:\\r\\n]+:\\h+\\K.+";
final String string = "April 01 2020 Key Information Read :: Interesting Character #1: Kermit the Frog\n"
+ "April 01 2020 Key Information Read :: Interesting Character #2: Miss Piggy\n"
+ "April 01 2020 Key Information Read :: Their Best Movie: The Muppet Movie (1979)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}