$re = '/::\h+[^:\r\n]+:\h+\K.+/m';
$str = 'April 01 2020 Key Information Read :: Interesting Character #1: Kermit the Frog
April 01 2020 Key Information Read :: Interesting Character #2: Miss Piggy
April 01 2020 Key Information Read :: Their Best Movie: The Muppet Movie (1979)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);