re = /::\h+[^:\r\n]+:\h+\K.+/m
str = 'April 01 2020 Key Information Read :: Interesting Character #1: Kermit the Frog
April 01 2020 Key Information Read :: Interesting Character #2: Miss Piggy
April 01 2020 Key Information Read :: Their Best Movie: The Muppet Movie (1979)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end