# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[a-z]++\s*)+|[^\s]+?)\s((?1)$)?/$1\n$2/gm;t' <<< "12345 my colour is red KG 5 4 7% 3 kitchen"