#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:[a-z]++\s*)+|[^\s]+?)\s((?1)$)?"
Local $sString = "12345 my colour is red KG 5 4 7% 3 kitchen"
Local $sSubst = "$1\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)