using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[a-z]++\s*)+|[^\s]+?)\s((?1)$)?";
string substitution = @"$1\n$2";
string input = @"12345 my colour is red KG 5 4 7% 3 kitchen";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}