$re = '/((?:[a-z]++\s*)+|[^\s]+?)\s((?1)$)?/m';
$str = '12345 my colour is red KG 5 4 7% 3 kitchen';
$subst = "$1\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;