using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://(?P<url_prefix>.+)\.cloudfront.net/(?P<folderpath>.+)/(?P<filename>.+)\..+";
string input = @"https://d2014f047udx1y.cloudfront.net/ecomm-recommendation/ecomm_recommendation_scrapped/2022_11_21/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJlbWFpbCI6Inlhc2guc2F0d2FuaUBtZmlsdGVyaXQuY29tIiwibmFtZSI6Inlhc2guc2F0d2FuaSJ9.wxogu4qEj42bZvjql5QHQJZkVGZuo1NmSbNRoav8bVk/B00XJELL5C/other_img/1.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}