import re
regex = re.compile(r"https://(?P<url_prefix>.+)\.cloudfront.net/(?P<folderpath>.+)/(?P<filename>.+)\..+", flags=re.MULTILINE)
test_str = "https://d2014f047udx1y.cloudfront.net/ecomm-recommendation/ecomm_recommendation_scrapped/2022_11_21/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJlbWFpbCI6Inlhc2guc2F0d2FuaUBtZmlsdGVyaXQuY29tIiwibmFtZSI6Inlhc2guc2F0d2FuaSJ9.wxogu4qEj42bZvjql5QHQJZkVGZuo1NmSbNRoav8bVk/B00XJELL5C/other_img/1.jpg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")