import Foundation
let pattern = #"https://(?P<url_prefix>.+)\.cloudfront.net/(?P<folderpath>.+)/(?P<filename>.+)\..+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://d2014f047udx1y.cloudfront.net/ecomm-recommendation/ecomm_recommendation_scrapped/2022_11_21/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJlbWFpbCI6Inlhc2guc2F0d2FuaUBtZmlsdGVyaXQuY29tIiwibmFtZSI6Inlhc2guc2F0d2FuaSJ9.wxogu4qEj42bZvjql5QHQJZkVGZuo1NmSbNRoav8bVk/B00XJELL5C/other_img/1.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)