re = /https:\/\/(?P<url_prefix>.+)\.cloudfront.net\/(?P<folderpath>.+)\/(?P<filename>.+)\..+/m
str = 'https://d2014f047udx1y.cloudfront.net/ecomm-recommendation/ecomm_recommendation_scrapped/2022_11_21/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJlbWFpbCI6Inlhc2guc2F0d2FuaUBtZmlsdGVyaXQuY29tIiwibmFtZSI6Inlhc2guc2F0d2FuaSJ9.wxogu4qEj42bZvjql5QHQJZkVGZuo1NmSbNRoav8bVk/B00XJELL5C/other_img/1.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end