using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?\bcar\b(?!.{0,10}\bnot\b).*";
string input = @"This car is not that fast!
The car you are about to see may not be that fast, but it's very beautiful!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}