re = /.*?\bcar\b(?!.{0,10}\bnot\b).*/m
str = 'This car is not that fast!
The car you are about to see may not be that fast, but it\'s very beautiful!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end