const regex = /.*?\bcar\b(?!.{0,10}\bnot\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\bcar\\b(?!.{0,10}\\bnot\\b).*', 'gm')
const str = `This car is not that fast!
The car you are about to see may not be that fast, but it's very beautiful!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}