import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]{2,}(?!.*(?:FO|SH|GDP|LDP).*).*$";
final String string = "12(3)/FO.2-3;1-2\n"
+ "153/G6S.3-H;2-3;1-2\n"
+ "1/G13S.2-3\n"
+ "22/FO.2-3;1-2\n"
+ "12(3)2S/FO.2-3;1-2\n"
+ "153/SH/G6S.3-H;2-3;1-2\n"
+ "45/3/H/GDP6;2-3;1-2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}