re = /^[1-9]{2,}(?!.*(?:FO|SH|GDP|LDP).*).*$/m
str = '12(3)/FO.2-3;1-2
153/G6S.3-H;2-3;1-2
1/G13S.2-3
22/FO.2-3;1-2
12(3)2S/FO.2-3;1-2
153/SH/G6S.3-H;2-3;1-2
45/3/H/GDP6;2-3;1-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end