import re
regex = re.compile(r"^[1-9]{2,}(?!.*(?:FO|SH|GDP|LDP).*).*$", flags=re.MULTILINE)
test_str = ("12(3)/FO.2-3;1-2\n"
"153/G6S.3-H;2-3;1-2\n"
"1/G13S.2-3\n"
"22/FO.2-3;1-2\n"
"12(3)2S/FO.2-3;1-2\n"
"153/SH/G6S.3-H;2-3;1-2\n"
"45/3/H/GDP6;2-3;1-2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")