#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.SYSCOP)([0-9]{2})(\.D%%ODATE)"
Local $sString = "TEST.SYSCOP01.D%%ODATE" & @CRLF & _
"TEST.SYSCOP02.D%%ODATE" & @CRLF & _
"TEST.SYSCOP03.D%%ODATE"
Local $sSubst = "\3\1.#\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)