import re
regex = re.compile(r"(\.SYSCOP)([0-9]{2})(\.D%%ODATE)", flags=re.MULTILINE)
test_str = ("TEST.SYSCOP01.D%%ODATE\n"
"TEST.SYSCOP02.D%%ODATE\n"
"TEST.SYSCOP03.D%%ODATE")
subst = "\\3\\1.#\\2"
result = regex.sub(subst, test_str)
if result:
print(result)