$re = '/(\.SYSCOP)([0-9]{2})(\.D%%ODATE)/m';
$str = 'TEST.SYSCOP01.D%%ODATE
TEST.SYSCOP02.D%%ODATE
TEST.SYSCOP03.D%%ODATE';
$subst = "\3\1.#\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;