const regex = new RegExp('(\\.SYSCOP)([0-9]{2})(\\.D%%ODATE)', 'gm')
const str = `TEST.SYSCOP01.D%%ODATE
TEST.SYSCOP02.D%%ODATE
TEST.SYSCOP03.D%%ODATE`;
const subst = `\3\1.#\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);