const regex = /^\Qhttps://\E(?:[^\/:]+\.)?gstatic\.(?:net|com)((?!recaptcha).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\Qhttps:\/\/\\E(?:[^\\\/:]+\\.)?gstatic\\.(?:net|com)((?!recaptcha).)*$', 'gm')
const str = `https://www1.www2.www3.gstatic.net/aaaaaarecaptchassssssss`;
const subst = `$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);