$re = '/^\Qhttps://\E(?:[^\/:]+\.)?gstatic\.(?:net|com)((?!recaptcha).)*$/m';
$str = 'https://www1.www2.www3.gstatic.net/aaaaaarecaptchassssssss';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;