use strict;
my $str = 'https://www1.www2.www3.gstatic.net/aaaaaarecaptchassssssss';
my $regex = qr/^\Qhttps://\E(?:[^\/:]+\.)?gstatic\.(?:net|com)((?!recaptcha).)*$/mp;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";