const regex = /^[0-9]+\s+[0-9]+\s+2\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+\\s+[0-9]+\\s+2\\s', 'gm')
const str = `134 1 2 6 3.45388e-06
135 1 2 7 3.04626e-06
136 1 2 8 4.69364e-06
137 1 3 9 4.21627e-06
138 1 3 10 2.38822e-06
139 1 2 11 1.91216e-06`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}