import re
regex = re.compile(r"^[0-9]+\s+[0-9]+\s+2\s", flags=re.MULTILINE)
test_str = ("134 1 2 6 3.45388e-06\n"
"135 1 2 7 3.04626e-06\n"
"136 1 2 8 4.69364e-06\n"
"137 1 3 9 4.21627e-06\n"
"138 1 3 10 2.38822e-06\n"
"139 1 2 11 1.91216e-06")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")