$re = '/^[0-9]+\s+[0-9]+\s+2\s/m';
$str = '134 1 2 6 3.45388e-06
135 1 2 7 3.04626e-06
136 1 2 8 4.69364e-06
137 1 3 9 4.21627e-06
138 1 3 10 2.38822e-06
139 1 2 11 1.91216e-06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);