const regex = /^((?:[A-Z0-9]+_?)+)(?<!_)=(?=(.*))|(<[^\/].*?>)|(<\/.*?>)|({\w*}%?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[A-Z0-9]+_?)+)(?<!_)=(?=(.*))|(<[^\\\/].*?>)|(<\\\/.*?>)|({\\w*}%?)', 'gm')
const str = `STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id="ICN_PRM_007"/>Wind attack power +{Perc}%
STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id="Yellow">reward</Color>, so give it your all!
STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}