import re
regex = re.compile(r"^((?:[A-Z0-9]+_?)+)(?<!_)=(?=(.*))|(<[^\/].*?>)|(<\/.*?>)|({\w*}%?)", flags=re.MULTILINE)
test_str = ("STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id=\"ICN_PRM_007\"/>Wind attack power +{Perc}%\n"
"STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id=\"Yellow\">reward</Color>, so give it your all!\n"
"STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")