#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w{5}\B)"
Local $sString = "hellosrae1231231312312312312322 i am marcopollo"
Local $sSubst = "\1- "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)