const regex = /(\w{5}\B)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{5}\\B)', 'gm')
const str = `hellosrae1231231312312312312322 i am marcopollo`;
const subst = `\1- `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);