import Foundation
let pattern = #"(\w{5}\B)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"hellosrae1231231312312312312322 i am marcopollo"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1- "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)