$re = '/(\w{5}\B)/m';
$str = 'hellosrae1231231312312312312322 i am marcopollo';
$subst = "\1- ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;